Templates Library products don't load once installed

Modified on Mon, 19 Oct 2020 at 10:50 AM

Using the free templates from the templates library is a really great way to get started and learn about how Fancy products are formed in layers.


Once you've chosen your product:and selected Yes when asked to add images to your media folder:

You should then be able to see your newly created product in the product builder product list:


If you edit a View, you might see the following:


This means FPD is stuck on finding the first image in the this product which has been set to a layer named "Base". 


One of the reasons for this can be that your Wordpress install doesn't by default allow SVG images to be uploaded. So when you pressed "Yes" to adding the product template images to your media folder - they weren't all actually added. You can check this by going to your media folder and trying to add an svg file like the one attached. If you receive the following error then you know this is the problem:



To rectify this, you can either:


1) Install a plugin like: https://wordpress.org/plugins/svg-support/


2)If you're familiar with editing functions.php, there are many snippets available for you to allow svg upload.

Was this article helpful?

That’s Great!

Thank you for your feedback

Sorry! We couldn't be helpful

Thank you for your feedback

Let us know how can we improve this article!

Select atleast one of the reasons
CAPTCHA verification is required.

Feedback sent

We appreciate your effort and will try to fix the article