Access-Control-Allow-Origin

Posted almost 7 years ago by medmouncef

Post a topic
Answered
m
medmouncef

Hello

Product Builder no longer displays the images that I used for the customization of my articles. And this before and even after today's update.

The message displayed at the bottom is :

"

Image with the URL
http://XXXXXXXXXXXX/wp-content/uploads/2016/09/10X12.png
can not be loaded into the canvas.

Troubleshooting

The URL is not correct!The image has been blocked by CORS policy. You need to host the image under the same protocol and domain or enable 'Access-Control-Allow-Origin' on the server where you host the image. Read more about it here.

"

What is in your opinion the origin of this problem and what the solution?


Thank you

3 Votes

rady kal

rady kal posted over 4 years ago Admin Best Answer

This is a server issue. You're running your server with ssl (https), but your content is still saved under http. You can fix this by:


1) Fixing your content URLs: https://wordpress.org/plugins/ssl-insecure-content-fixer/

2) Under the status page (in the FPD menu), use the reset image source tool to fix the image URLs saved by FPD in the database.

0 Votes


15 Comments

Sorted by
D

David Fozdar posted almost 7 years ago

This problem occurs for me when I use a CDN (maxCDN) via W3 Total Cache (plugin). I have to exclude every image I use as a background from using CDN, then I don't have the problem (you can exclude files or folders in the W3 Total Cache plugin options). I would assume this happens for any CDN service enabled.

 

0 Votes

s

sashen naidoo posted over 6 years ago

I have this problem also. 

my background images dissapear when I take my site into production mode, my servers uses maxCDN.

"Production mode will speed up your site by using the server caching and CDN that we have in place"

I use wordpress/woo. How can I overcome this?

0 Votes

W

Wendel Gart posted over 6 years ago

You have to enable CORS on the CDN-server. For more information check: https://enable-cors.org/

0 Votes

B

Bala Nagendran posted over 6 years ago

"Image with the URL
http://XXXXXXXXXXXX/wp-content/uploads/2016/09/10X12.png
can not be loaded into the canvas."

Troubleshooting

The URL is not correct!The image has been blocked by CORS policy. You need to host the image under the same protocol and domain or enable 'Access-Control-Allow-Origin' on the server where you host the image. Read more about it here.

How to solve this.Please reply as soon as possible.It will help me a lot.


Note:This is happened when using localhost not on live server.

0 Votes

K

Kevin Okragly posted about 6 years ago

We have the same issue and it happens intermittently.  We are not using caching, and we are not using a CDN.  The URL of the image that throws the error is exactly the same as the site URL, both using HTTPS (see the screenshot).


Please advise on what can be done to fix this error.


Thanks,

Kevin

0 Votes

A

Adam Balsamo posted almost 6 years ago

I was able to resolve this by forcing HTTPS on my site Wordpress site (hosted on Siteground).  I added this to my .htaccess file in root

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://%{SERVER_NAME}%{REQUEST_URI} [R=301,L]
</IfModule>

0 Votes

s

sk963070 posted almost 6 years ago

Hi,


I am getting this error (The element Design does not have a valid JSON object as parameters! Please check the syntax, maybe you set quotes wrong.) .


It's not working on https.


Thanks 

0 Votes

G

Gail Cruickshank posted over 4 years ago

I have this issue: 


The image with the URL
https://secureservercdn.net/160.153.137.16/qxv.bec.myftpupload.com/wp-content/uploads/2019/11/Tshirt2-Back-2.png
can not be loaded into the canvas.


Troubleshooting

The URL is not correct!The image has been blocked by CORS policy. You need to host the image under the same protocol and domain or enable 'Access-Control-Allow-Origin' on the server where you host the image. Read more about it here.


I've read several solutions on here  but I am unsure where I should be adding the code (I am a complet novice). I am using woocommerce (godaddy/wordpress) PHP 7.2 


Thanks

0 Votes

rady kal

rady kal posted over 4 years ago Admin Answer

This is a server issue. You're running your server with ssl (https), but your content is still saved under http. You can fix this by:


1) Fixing your content URLs: https://wordpress.org/plugins/ssl-insecure-content-fixer/

2) Under the status page (in the FPD menu), use the reset image source tool to fix the image URLs saved by FPD in the database.

0 Votes

R

Richard Geer posted about 4 years ago

I am having a similar issue on GoDaddy Managed Wordpress running their native CDN. 


The image with the URL
https://secureservercdn.net/198.71.233.96/l6c.1ca.myftpupload.com/wp-content/uploads/2018/04/Brick-Texture.png
can not be loaded into the canvas.


What should I put in the reset image source tool to force a reset? 


Any info would be great, thank you.


0 Votes

rady kal

rady kal posted about 4 years ago Admin

You can try the following options to solve it yourself: 


1)https://support.fancyproductdesigner.com/support/solutions/articles/5000592148-common-problems-and-solving-them 

  (If you moved your site from http to https for example)


2) or you have to enable CORS on the CDN-server. For more information check: https://enable-cors.org/.


Otherwise please open a support ticket on our website so we can have a closer look at your issue. 

0 Votes

r

ram posted over 1 year ago

Hi ,
Developers how can i use fancy product Designer by cdn at localhost in .html or .php file

0 Votes

Matt Taylor

Matt Taylor posted about 1 year ago

I AM HAVING THE SAME ISSUE TOO. WHY DON'T THE DEVELOPERS FIX THIS REDICUOUS NONESENSE OR STOP SELLING THIS PRODUCT

The image with the URL
https://kda365.s3.amazonaws.com/wp-content/uploads/2023/02/24183034/Tshirt-Front.png
can not be loaded into the canvas.


Troubleshooting

  • The URL is not correct!
  • The image has been blocked by CORS policy. You need to host the image under the same protocol and domain or enable 'Access-Control-Allow-Origin' on the server where you host the image. Read more about it here.


0 Votes

rady kal

rady kal posted about 1 year ago Admin

@Matt I already explained in your ticket, that this is not a bug from our plugin and more a security issue implemented by the browsers and servers to prevent loading assets from one website into another one without permission. As you are hosting your images in a CDN or any remote server which is not equal (same domain and protocol) where you run the product designer application, you have to enable CORS on your CDN (image server).


Here is a blog entry explaining more about that.


We can not enable CORS for you because we do not have access to your CDN/Server and there are plenty of different cdn servers. 


If you want to find out how you can enable CORS on your server, just google for it or ask your provider.


Here are also some helpful articles how you can do that for specific environments or for AWS S3.

0 Votes

D

Danny posted 8 months ago

Did someone managed to solve this issue? I have the same issue, CDN disabled, CROS enabled through htaccess file and still getting the same error while trying to load the product in viewer admin area.

0 Votes

Login or Sign up to post a comment