disable minimum dpi?

Posted almost 9 years ago by Adam Keen

Post a topic
Answered
A
Adam Keen

I seem to keep getting a dialog box popup saying minimum allowed DPI. It was originally set to 72 for minimum and was getting this Error so I lowered it to 24 and I still get the error. How can I disable this dpi check? I've checked with a few photos and It seems to keep recurring. I've checked DPI of these photos and they are 72 so I don't understand when it's set to 24 its still getting an error? I've tried on both mozilla & IE. Any ideas anybody?



0 Votes

A

Adam Keen posted over 8 years ago Best Answer

yeah all setup matey. I've set mine to 24 dpi and today had a customer message me saying they can't upload their photo. So they emailed me it. The DPI was 24 so why is this not allowing upload? I mite set the minimum to 1 to prevent this error as its causing nightmares for me haha.

 

0 Votes


20 Comments

Sorted by
N

Nimit Chavda posted over 4 years ago

where to change dpi information in woocommerce backend. Is there any php/js file to change to make it 1.

0 Votes

P

Paulo Carrasco posted over 8 years ago

The problem resides in the way that the resolution is read from files. The resolution is not located in the same spot in the header file, and it differs from file format to. The function has to be refined to contemplate different file types and exif versions.

0 Votes

J

Joe Kardos posted over 8 years ago

Thank you for the suggestion. Unfortunately 299 does not work. I also tried 72. Only seems to accept JPG format if it is set to 0. And I assume most customers images will be jpg. Any thoughts?

0 Votes

A

Adam Keen posted over 8 years ago

Try 299 Joe seems to work setting it -1 below the DPI your wanting hope this works for you then test a 300 DPI photo.

0 Votes

J

Joe Kardos posted over 8 years ago

I would like to be able to set this to 300dpi because I would like to make sure the customers pictures are not too low to print. Is there a solution to help make this actually work? Setting it to 0 will just allow any sized picture to upload and this would cause a problem for my product.

0 Votes

A

Adam Keen posted over 8 years ago

0? I'll change it to 0 then thanks paulo

0 Votes

A

Adam Keen posted over 8 years ago

I noticed if the DPI is set -1 of the actual DPI it work. For example setting the DPI to 23 of an image with 24dpi works but if you set it to 24 the same of the tested source you get an error message. I resolved this by setting it to 1 to prevent this from happening to customers

0 Votes

P

Paulo Carrasco posted over 8 years ago

Better using 0. The read function may pick up a zero from the file header ;)

0 Votes

A

Adam Keen posted over 8 years ago

Yeah same I've noticed this, also set mine to the minimum of 1

0 Votes

P

Paulo Carrasco posted over 8 years ago

What I've found until now:

- You have to activate PHP Uploader

- If you upload a PNG it detects it without any error message, the same image converted do JPG gives de error message imediatly


So. The DPI detection needs a better implementation! I've taken a peek to the code and the get_image_dpi function does a basic FileRead, reads 20 bytes and extracts the DPI from that 20 bytes. This approach is dangerous because the  Exif XResolution and YResolution can be in different positions in the file header depending on the camera model that creates the file, so, the only solution I've found to circumvent this problem is to set the Minimum DPI field to 0 (and not 1 because the returned bytes can be 0 !).


0 Votes

A

Adam Keen posted over 8 years ago Answer

yeah all setup matey. I've set mine to 24 dpi and today had a customer message me saying they can't upload their photo. So they emailed me it. The DPI was 24 so why is this not allowing upload? I mite set the minimum to 1 to prevent this error as its causing nightmares for me haha.

 

0 Votes

a

alexus posted over 8 years ago

Guys you tested it under admin account? Cant understand why i can upload any images and get no errors even if 300dpi is set in options

 

0 Votes

A

Adam Keen posted over 8 years ago

Yeah Hua Huang, I was getting the same error, hopefully developer will see this and fix the error. In the meantime do what I did and set it lower then the actual dpi you want it to be. so set it to 71, I personally set it to 24 in the meantime so my customers don't get the error.

 

0 Votes

h

hua huang posted over 8 years ago

I set the Minimum Allowed DPI 72, but got an error.Picture resolution is 72

0 Votes

A

Adam Keen posted almost 9 years ago

Doesn't work for me either :P haha.

 

0 Votes

a

alexus posted almost 9 years ago

Its cool, because when i set in options dpi minimum to 300 it allow to load files with 72dpi. Hmm......Looks like it just not work for me

 

0 Votes

A

Adam Keen posted almost 9 years ago

 

 Attached error Below of what I was getting. I lowered the minimum DPI which fixed the problem for 72 dpi photos. However it wouldn't of been getting this error when set to 72 as like I said photos were 72 DPI checked in properties & checked in photoshop. However not to worry, Problem resolved. (admin mark this as solved)

The DPI of the uploaded image is too small! Minimum allowed DPI is 72

 

0 Votes

a

alexus posted almost 9 years ago

What error he get? Word by word, can you copy paste? DPI option affect only export for admin.

 

0 Votes

A

Adam Keen posted almost 9 years ago

Think the problem has resolved itself by changing it to 24. Strange how even though the photos I tested were 72dpi & minimum dpi was set to 72 it wouldn't allow me to upload them because of a DPI error. However when lowering it fixed it. Not at first however I think that was down to a caching problem.

#Alexus / problem was user interface side, when customer clicks add photo and selecting image.

 

0 Votes

a

alexus posted almost 9 years ago

What the error you get? Word by word. How i understand dpi option work only for export by admin

 

0 Votes

Login or Sign up to post a comment