Issue with Loading Saved Designs in Fancy Product Designer

Posted 11 months ago by Yılmaz DURU

Post a topic
Un Answered
Y
Yılmaz DURU

Hello everyone,

I hope you're doing well. I'm facing an issue with the "Fancy Product Designer" on my online e-commerce website, durugrfx.com.tr. The integration of the plugin itself seems to be working fine, but I'm having trouble loading saved designs. ( eg. Page: https://www.durugrfx.com.tr/urun-tasarla/sapka-9)

When attempting to load saved designs, the page displays a continuous "LOADING..." message without actually completing the loading process. This problem occurs both in the admin panel and on the front-end when customers try to access the "Design Your Own" section. The design editor seems to open, but it's stuck in a loop of attempting to load the design and showing the "LOADING..." message indefinitely.

I have checked the browser console for errors, and I found a "DevTools failed to load source map" error related to Bootstrap. However, I don't believe this error is directly causing the issue with loading saved designs.

I've reviewed my code and verified that file paths are correct. I've also looked into the JSON data used for products and designs, and they seem to be set up correctly.

I'd appreciate any insights or guidance on how to resolve this issue. If anyone has encountered a similar problem or has suggestions for troubleshooting, I would be grateful for your assistance.

Thank you in advance for your help.

Best regards, [YILMAZ DURU]




0 Votes


2 Comments

Sorted by
Y

Yılmaz DURU posted 11 months ago

I am an advanced-level programmer and despite putting in a lot of effort, I couldn't resolve the issue. I suspect that the problem lies within either Jquery or Js. If there were a conflict with the server or PHP, it would be visible in the logs, but I can't find any issues there either. The only remaining possibility is an issue with Jquery, most likely stemming from its new version.

I'm relieved to know that I'm not the only one facing this problem :) Otherwise, I would have felt inexperienced and downhearted :))

With the current version, I am unable to load files in the same manner for the products I generate in the admin panel, both on the Front-end and Back-end. The process gets stuck on the loading page continuously

0 Votes

A

Anna Moyer posted 11 months ago

I'm also having this problem. Orders that were saved by users using v5 don't load into the v6 product designer. Nothing happens when I click on the icon to load them.

1 Votes

Login or Sign up to post a comment