Layers Missing on Products since Upgrading

Posted almost 6 years by Tracy Ryan

Post a topic
Answered
T
Tracy Ryan

Is anyone having the same problem? Every single one of the Fancy Products I created in the past are now missing layers. What's really strange is that on our live website the products appear fine, meaning the layers that have disappeared in the product builder appeare and can be customized.  The images for the missing layers are in the image gallery so it's not like they got deleted or anything.  The two possible solutions that the FPD developers recommended didn't fix the problem. Thanks.


0 Votes

D

Deleted Agent posted almost 6 years Best Answer

That only happens if you have at some point switched from http to https - you'll need to go through your database and replace the http URL's with https (search and replace).

0 Votes


11 Comments

Sorted by
K

Katrina Morris posted about 5 years

Nevermind! We also went from a staging server to a live server, so the base url changed. I ran the replace queries above and all the views are back!

Thank you.

 

0 Votes

K

Katrina Morris posted about 5 years

I ran the above queries and they all worked except the last. I got the following error message:

#1146 - Table 'shopmeo_wordp.wp_fpd_templates' doesn't exist

My layers are still missing in the product builder after going from http: to https:

Thank you.

 

0 Votes

O

Ove Brandt posted over 5 years

You can run these queries to fix missing layers when you have switched to https:


REMEMBER TO BACK UP FIRST! Dont blame me if it goes to shit!


update wp_fpd_views SET elements = REPLACE (elements, 'http:', 'https:')

update wp_fpd_views SET thumbnail = REPLACE (thumbnail, 'http:', 'https:')

update wp_fpd_products SET thumbnail = REPLACE (thumbnail, 'http:', 'https:')

update wp_fpd_templates set views = REPLACE (views, 'http:', 'https:')


This fixed it for me, and yes, i did a backup first, just in case.

0 Votes

D

David Conway posted over 5 years

Images and layers disappear on admin side for Images above 10000 pixels (length or width), since upgrade.

 

0 Votes

G

Gerrit Ekelmans posted over 5 years

Hello all, how do you resolve the missing layers? I'm strugling now after the last update Thanks for the reply

0 Votes

R

Rhiannon Doyle posted almost 6 years Admin

Tee Mo I have this left aligned text issue too!

I can't work out where it was introduced but I can't find a reason for it.

 

0 Votes

T

Tee Mo posted almost 6 years

Same issue. Layers appear on the frontend, but I am unable to see or edit layers in the Fancy Product Builder backend. 

Has anyone found an actual solution?? 

I also have a separate issue with my text layer appearing as left aligned (when it is supposed to be centered) on mobile browsers

0 Votes

D

Daniel de Bianchetti posted almost 6 years

In my case the images only disappear from the backend of FPD (product builder) however in frontend the images are ok

In the tables of:
_wp_fpd_products
_wp_fpd_templates
_wp_fpd_views
All URLs are on https

Attachments (1)

0 Votes

D

Daniel de Bianchetti posted almost 6 years

OK, What are the tables, please?

 

0 Votes

D

Deleted Agent posted almost 6 years Answer

That only happens if you have at some point switched from http to https - you'll need to go through your database and replace the http URL's with https (search and replace).

0 Votes

Efbi

Efbi posted almost 6 years

Same problems here 

0 Votes

Login or Sign up to post a comment