Welcome to the support center for

Fancy Product Designer & Multistep Product Configurator


Forbidden / OK popup when uploading an image


when trying to upload an image sometimes it's working great, sometimes it says forbidden and sometimes it shows OK but do nothing.

we have tried to maximize the file upload and all this but nothing.

Any help please?


also notice, it depends on the user roles. as administrator i can upload, but someone else (buyer..) can't upload.

Maybe there is an option to disable? or even something with the host?

Thanks again

I've had this problem, but it was because I messed with my PHP version in the cpanel.

I also think it was only giving me problems with facebook and instagram uploads.

actually we did nothing to the php version / cpanel..

how did you solve it? :)

My problem was because I had the wrong PHP version set.

I was using PHP 5.2.  Then I thought I read somewhere in the FPD changelog that I could use PHP 7.0.  But then I started getting that error so I changed it back to 5.2 and it worked.

So, i've checked and my php version is 5.4

should i edit it to be 5.2?! in order for it to work.... it sounds weird, no?

maybe update it to 5.6?! 

give it a try. you can always just change it back

Yeah man, thanks for the help but it's still happaning.

when i try to change my server php to 5.2 (the website doesn't load at all saying something is missing...) so i've tried to change it to 5.6 (newer version..)

but still no luck.

btw, i notice something weird that when i'm administrator it's working fine but when i'm using incognito / other user not admin it's not working, saying FORBIDDEN.

any other suggestion please??


Ah sorry to hear that.  I don't know.  The only other thing I can think of is make sure your images are being uploaded to a server.

I've had to work out so many kinks and produce so many work arounds that I dont remember everything I did.  But I can't think of anything else to solve that, If I do I will let you know.

Good Luck

Hi Stanley, first of all thank you so much for the quick reply and the help!

i've just found what it was! it's WORDFENCE

the plugin for security.

nevermind:) got it solved thanks to you!

I have the same problem but only on certain image. It says OK on white popup. Any other solution? 


I have the same problem here. Gives me OK error. Has anybody fixed this issue?

Any new feedback or update on this? If Wordfence is interfering, did you remove it or just have some settings adjusted on wordfence end?


In most cases this is caused by your server configuration - a missing php class or function which is necessary for the upload process. But its only possible to tell you when you share your WP site url in a support ticket.

Deactivating Wordfence solved this problem for us as the plugin was causing this issue.

Login or Signup to post a comment