Welcome to the support center for

Fancy Product Designer & Multistep Product Configurator


Order not loading in order viewer when question mark used


After updating  our site to the latest versions (WordPress 4.5.3, WooCommerce 2.6.1, Fancy Product Designer 3.2.1), the product doesn't show in the order viewer (view order > Load in order viewer) if a question mark is used by the customer (Add Text Layer).

I can reproduce this in the demo (http://demo.fancyproductdesigner.com/ ) on your site.


Thanks for bringing this up! I'll let the developer know.

I have the same problem. A few customers ordered a product with a question mark in the original text of the product and the order would not load in the order viewer. I have since ordered all kinds of products on my own site, and they would work without a question mark but as soon as I added a question mark, the order would no longer load in the order viewer. 

This is rather peculiar; what is different about a question mark? 

Have you guys found out what causes this problem? Please release a fix for this, I would appreciate it immensely.

I have tried to use older versions of the fancy product designer, but the problem persists, at least with orders that have already been placed. So there is no way to get to the designs my customers have made. I must say, this is extremely frustrating.

Hi Jelmer,

Yes, I totally agree it's frustrating. I've reported the issue 1 month ago and the only answer I got is "I will check this within the next update" and the ticket is closed by the developer. I didn't except that such a serious bug hasn't been fixed yet - and no more people have reported it. As I reported a month ago I have also reproduced the issue on the demo of the plugin. So more must have this issue and your comment doesn't surprise me. 

I don't know if the people of Fancy Product Designer read your comments, because this is only a discussion forum. Maybe you can submit your own support ticket?

Meanwhile we did a rollback of the site to the previous version...

Thanks for your response, Peter! The rollback of the plugin fixed the problem? Which version of the plugin? Because when I try with older versions, I seem to have the same problem. At least for orders that had already been placed. 

It seems to have to do with question marks breaking the code of the json. 

And I agree with you, you would expect such a bug to be fixed. But it takes time to update these kinds of plugins, I respect that. Some more information would be useful, however.

As far as tickets, my support has run out a month ago or so, so I don't know if I can then still open a ticket.

I've tried finding the orders in the database and removing the question mark from there, but then I do not even get a load button on the woocommerce order page. 

I did a restore of a full backup made before the update. As far as I know there no way to view not-working orders with a question mark. Now waiting for the fix.

I think you can submit a ticket, because you have bought the product.

I see. And after the restore, subsequent orders placed with a question marked worked fine?

Ok, I'll submit a ticket!

Yes. Orders with questions marks always worked, until the update. So after complete restore (all website files and database) they still work for new orders, because we don't use the update anymore.

Okay, that is good to know. It might be a conflict with a newer version of woocommerce or wordpress, or a new bug in the software of the plugin itself.

I've figured out a rudimentary fix: in the database you can find the fpd order. Wherever there is a question mark, I've changed it into an exclamation point and then the order loads just fine.

According to support, this issue will be fixed in the next update.

Thanks Jelmer!

Login or Signup to post a comment