Welcome to the support center for

Fancy Product Designer & Multistep Product Configurator


SVG Settings

My .svg files have not been working on my site for quite sometime.  The display, scale, move etc but on click they do not allow you to change the color of the various paths like when I first started using this plug in 2014 

My question is does anyone have any tips on how to create svg's in Adobe Illustrator?  Which settings? etc.  

1 person has this question
Hi there,

have you been upgrading FPD regularly? The reason why I ask is that there's a "color picker for every path" flag for svgs (under color tab) that I don't think was in previous versions.


Hi... Yes... I get the email alerts and update every immediately... I get one color picker, regardless of number or paths in the svg and even then the svg doesn't change colors. I believe Radykal looked sometime last year and said the svgs had errors. So my assumption is I'm not saying them correctly in Illustrator as it seems I'm the only one not able to use svgs

Ah I see. Ok try the svg I've attached, if color picker for all paths flag is set you should be able to see all colours from the file.


Thanks for your file.... I uploaded it to my site and made sure to check off Yes on the Colorpicker

I'm guessing I may have some other conflict because I still can not change the colors from the front end.



Thanks... I uploaded the AnchorsBack.svg to my site and made sure the Color Picker for every Path was set to Yes.

There must be another conflict because on the front end I am still unable to see color options for each path.

I attached screens

Hmm I'm not able to recreate that using the same svg. The only thing I can see is different Modification settings... but I've tried a few different combinations and I always get the paths with a colorpicker for each.

I'm guessing it's not a server issue if it was working ok up 'til now?


Not sure which release this issue started in but looking through my support tickets @ http://radykal.freshdesk.com/ I did reach out for help 7 months ago about the same issue.

Is there a way to do a fresh install, totally delete the FPD folder and upload the latest, or should I start with the old disable all my plug-ins methods and see if there's a conflict?

Try it on a fresh install. Just rename current plugin to fancy-product-designer_bk then download latest version from codecanyon, upload it and see if that works.

If not then do try disabling plugins. 

Does colour changer work on pngs? 


PNG's work just fine, no issues there that's why I figured the problem must be the .svg's 

I'm going to try a fresh install.. I tried disabling other plugins before I opened a ticket 7 months ago but that didnt fix it, I guess a fresh install may be in order now

Ok.... I tried a fresh install....

Made a backup of the most recent setup then followed the instructions from "http://support.fancyproductdesigner.com/support/solutions/articles/5000582931-upgrading"

1. Deleted everything

Deleting all database tables to start from scratch

If you want to delete all database tables that are created by the plugin when deactivating the plugin, you need to uncomment one line of code.

Open class-install.php in the inc folder of the plugin.Go to line 16, looks like that:
//register_deactivation_hook( FPD_PLUGIN_ROOT_PHP, array( &$this,'deactive_plugin' ) );Remove the first two trailing slashes to uncomment the line, so it looks like this:
 register_deactivation_hook( FPD_PLUGIN_ROOT_PHP, array( &$this,'deactive_plugin' ) );Save the php file.

Now when you deactivate the plugin, all your created Fancy Products etc. will be deleted.

2.  Setup one Fancy product using the AnchorsBack.svg

3.  Added a base, shadow and the image layers

4.  Set the svg layer Color Picker option to Yes for every path

Still not working

5. I disabled all my plugins except FPD and Woocommerce

Still got the same color picker as before I did all this

At a loss right now. Guess Im going to have to take down my Fancy Products

Could you try a product without the other layers, just the svg?

Same thing.... Unfortunately.  I didnt redo a fresh install

Tried it with some of my svg's also...Same result

Thanks for your help with this

Just so I'm clear... when you click the red swatch in the toolbar, nothing happens right? You don't get the sub-toolbar or a color picker?

Login or Signup to post a comment