Welcome to the support center for

Fancy Product Designer & Multistep Product Configurator


bug in "individual product settings" - UI Layout change dropdown not working - solved

 Hi all,

even though we created two or more different User Interface Layouts in the composer,
we could not select any one of these in the "individual product settings"

The dropdown arrow was clickable, and the arrow changed from pointing down to pointing up,
but none of the names of those individual layouts appeared.

We solved this by changing the following:

line - 33
find - <select name="product_designer_ui_layout" class="radykal-select2">
replace with - <select name="product_designer_ui_layout" class="">


now it works fine.

see screenshot

Thank you this helped I was able to select the UI, but even though its selected for the individual product. The UI that shows up is just the default one.

Are there any other steps you can share with me or did that completely solve the problem for you?

Make sure you create at least one additional UI Layout, save it under a distinguishable name and then it should work. There are no other steps


Thank you I will give it another try. In a odd way it worked as you suggested originally, BUT the options for example magnify still show up even if removed from the new UI layout. Solution was to remove it from the default one as it seemed to apply the change to all of the UI's.

Thank you

Yes I had the same problem. To remove module/action option icons I had to remove them from the default UI also.
Until I read this post I was stumped, so thank you (I think it is a bug).

If you are on the most recent version there should be no more issue with this (currently 3.3.0) The issue existed back in 3.1.X I believe.

It is version 4.1.5 by now and it still doesn't work...

works for us. Please open a support ticket so we can have a closer look at your issue. 

I had it working by using the method described by Etienne Renaud, 4 years ago. But Markus said there should be no more issue on version 3.3.0, but the issue still exists now, on version 4.1.5. Nonetheless, I started to make an app like FPD for a client, but gave up once I found about FPD and I am now using it, and I realize how much effort was put in this plugin. So thank you for the great work!

It should work in V4.2.1, we changed the jquery plugin to display the dropdown.

Login or Signup to post a comment