Welcome to the support center for

Fancy Product Designer & Multistep Product Configurator


Text moves to upload zone - bug???

We have several customizable print products on our site, and have come across a major issue.

With the latest release 3.0.3 - if a user clicks an upload zone, the photo upload/gallery sidebar automatically opens. If the user then clicks on text to edit without closing the sidebar, and begins to edit the text, the text is placed inside the upload zone.

It seems like the originally defined text area and bounding box are removed from the design and the text will only show up inside the upload zone.

I know it is easily avoidable by closing the photo sidebar before clicking on text to edit. However, my clients are constantly forgetting to close the sidebar and are getting frustrated to the point of not using my services anymore.

Does anyone know if there is a setting in FPD that can avoid this situation? I have the upload zones set to Custom Texts - No. I have even tried Custom Texts - Yes just in case it was programmed backward, but there issue still happens.

This is not only on my site, but happens on the FPD demo site as well.

Test the greeting card demo - http://fancyproductdesigner.com/product/greeting-card/

First, click the "Add Your Image Here" area. The side bar opens. Leave it open and click the editable text "Enter your holiday message". Begin typing inside that text area and the text will automatically be placed into the large upload zone on the right.

We would prefer for the sidebar to automatically close when the photo is populated in the upload zone or once the user clicks on the photo that was placed in the upload zone - similar to the way the photo gallery would close in versions 2 once the photo was selected.

I have asked an outside programmer to look into this issue but wanted to see if this is going to be fixed in an upcoming release first. OR if anyone knows how to fix this, please share!

Apologies about the late reply and thank you for bringing up this issue. Sorry I do not think there is a setting that will fix this. We'll look into it and fix it as soon as we can.


I have just had this issue come back with the latest update. 3.4.0. Beforehand everything was working fine.

If I import the image in first and then edit the text the text then replaces the image as screenshots below. However if I edit the text then import the image last it works fine. I know this however try explaining this to lots of estate agents!!!!

Was there a fix for this somewhere or is this a new issue? Please could you help as I have tried various attempts at fixing with no luck. Debug is ok and I have turned on jquery no conflict + I am not getting any browser errors. I have also tested on various browsers.

Kinds Regards and hopefully should not be too hard a fix





This will be fixed in next update, coming in few hours.

Great stuff... thanks for the quick reply. Cheers Rob

Facing the same problem, Have this fixed?

Login or Signup to post a comment