Welcome to the support center for

Fancy Product Designer & Multistep Product Configurator


Adding Google fonts


I feel quite stupid by making this question but I have to since I can't seem to do this!

I have read the documentation and tried pretty much everything to add Google fonts to my project. I can't do it! Shouldn't I be able to just import the fonts via CSS and add them on the Fonts tab? Because that doesn't work. Am I forced to download the fonts? Am I forced to add them manually on the jquery.fancyProductDesigner-fonts.css?

P.S. - I am working on a localhost if this matters...


You should be able to just select the google fonts in the general settings of FPD:

I've just tested this on my local machine and it's working fine.

I do know where one should be adding the fonts. The only issue is that the only thing I get is "No matches found"...


 I'm having this issue too on FPD 3.1.1 with WordPress. Do we need to manually load an extra script?

There should in general be no issue with this, if you are experiencing one, please open a ticket.

I'm having the same problem, can you tell me please how did you solved it?


I am having the same problem.


Please advise.

Experiencing the same problem. Latest wordpress, latest woocommerce latest plugin. Everything is on a new setup.


I have the same problem.

It says "No results found". Before latest updated, this was working right.

I found the issue, it only happens in the latest update. You can easily fix by yourself:

  1. Open inc/settings/class-fonts-settings.php
  2. Go to line 66: 
    if ( empty( $optimised_google_webfonts ) || true ) {
  3. Remove || true:
    if ( empty( $optimised_google_webfonts ) ) {

I will also fix in next update, which is coming the next days. Sorry for the problem!

Thank you for your reply, but I did what you said and it still doesn't work

Yes because too many api request are made right now, I need to update the plugin with a new api key, then it should work again!

Okk! Perfect, thank you!

After changing 

if ( empty( $optimised_google_webfonts ) || true ) {


if ( empty( $optimised_google_webfonts ) ) {

I am still getting the No results found message.

Login or Signup to post a comment