Please rename meta key "fpd_data" to "_fpd_data" with "_" prefix which mark it as "hide" meta.
Many plugins try to show it as variation meta.
Included in V3.4.9
seems it is not all the files changed correctly
they both operate only with "fpd_data" meta key (era before 3.4.9)